Monthly Archives: April 2014

What you need to know about Heartbleed

Recently, a major security vulnerability named "Heartbleed" has made headlines around the world. This is a severe vulnerability stemming from a coding mistake in a widely-used security utility called OpenSSL. The bug affects the encryption technology designed to protect your sensitive data on the Internet, like usernames, passwords and emails. This is a flaw in t ...
Read more